requires.io | Wed 21 May 2014 Alexis Tabary

Requires.io helps you keep track of the requirements of your Python projects. Alas sometimes you actually want use an older version of a package, or an LTS release.

Today we are introducing a directive for requirements.txt files: rq.filter. It's very simple to use and to understand: with it you specify which subset of releases you want to check a particular requirement against.

Let say for instance that you use Django 1.5, but cannot yet upgrade to Django 1.6. You can just make your requirements file like this:

django==1.5.5  # rq.filter: >=1.5,<1.6

You will now be notified when a new version of django 1.5 is released, but not django 1.6. Also, your badge will show an up-to-date status.